Wednesday, December 13, 2017

#1 2009-09-27 04:41:54 pm

leonsimard
Member
From:: Montreal, Canada
Registered: 2009-09-27
Posts: 526

AppleScriptObjC app running on 10.5.8?

Hello!

I'm new to these forums. I have done a lot of scripting and used Script Editor before switching to AppleScript Studio, which was a big step for me, but such an improvement over what I used to do that I never went back.

But now, I have to say that although it is a another big change, this one is the best thing Apple has done to help us move to the next level in programming. I believe that to be the last big change, as I don't see anything else but remove ASS from Xcode altogether to make us go to the next one which is pure Cocoa (which I am slowly learning, looks much more powerfull!).

I would like to thank everyone who is helping everyone of us make the switch, especially those who seem to have Cocoa knowledge already, for you this surely makes sense to you, more than us.

Finally, my question!

Did anyone try to run AppleScriptObjC created apps on OS 10.5.8? I tried with 10.5.7 at work, but in the logs it says that (obviously) it's missing the AppleScriptObjC.framework. Maybe Apple included it with the 10.5.8... can't try it at work for now, it's not officially approved for use by our IT department yet. 10.6 will take more time to get approved and everyone to get it on their machine...

The reason is I have many new ideas of apps I want to make for our company, but If i'm the only one who can make them work, there is not much point to write them all in ASOC. Strange for Apple to "force" us to switch to 10.6 like this, without a solution...

Model: MacBookPro2,2
Browser: Safari 531.9
Operating System: Mac OS X (10.6)


Filed under: AppleScriptObjC, 10.6, 10.5.8

Offline

 

#2 2009-09-27 04:46:04 pm

StefanK
Member
From:: St. Gallen, Switzerland
Registered: 2006-10-21
Posts: 11482
Website

Re: AppleScriptObjC app running on 10.5.8?

Hi,

AppleScriptObj does definitely not run on Leopard as Objective-C 2.0 does not run on Tiger


regards

Stefan

Offline

 

#3 2009-09-27 05:37:50 pm

leonsimard
Member
From:: Montreal, Canada
Registered: 2009-09-27
Posts: 526

Re: AppleScriptObjC app running on 10.5.8?

Oh really? Obj-C 2.0 only came with Snow Leopard?

What about this web page:

http://developer.apple.com/leopard/over … ivec2.html

It talks about Leopard, not Snow Leopard... i am confused.

Maybe if we try copying the framework from 10.6 to 10.5? I see it is located in the System/Library/Frameworks/.

Offline

 

#4 2009-09-27 05:44:34 pm

StefanK
Member
From:: St. Gallen, Switzerland
Registered: 2006-10-21
Posts: 11482
Website

Re: AppleScriptObjC app running on 10.5.8?

leonsimard wrote:

It talks about Leopard, not Snow Leopard... i am confused.


I wrote:

…does not run on Tiger


leonsimard wrote:

Maybe if we try copying the framework from 10.6 to 10.5? I see it is located in the System/Library/Frameworks/.


Which part of "does definitely not run" is capable of being misunderstood wink


regards

Stefan

Offline

 

#5 2009-09-27 05:57:32 pm

leonsimard
Member
From:: Montreal, Canada
Registered: 2009-09-27
Posts: 526

Re: AppleScriptObjC app running on 10.5.8?

In your initial reply:

"AppleScriptObj does definitely not run on Leopard as Objective-C 2.0 does not run on Tiger"

I saw Tiger in the mix and got confused, but now I understand. Sorry about that.

I know that ObjC 2 is not backward compatible with the original, but if AppleScriptObjC only needs a framework to run, why wouldn't it be possible to make it work under 10.5? At least 10.5.8...

The thing is, I have seen nothing in these forums, neither does a Google search return a thing. I could not test it under 10.5.8, but I assumed that once the app was compiled, everything would be good... but nope!

Thanks, i guess i'll keep on testing.

Offline

 

#6 2009-09-27 06:20:50 pm

Shane Stanley
Member
From:: Australia
Registered: 2002-12-07
Posts: 5199

Re: AppleScriptObjC app running on 10.5.8?

leonsimard wrote:

but if AppleScriptObjC only needs a framework to run


That's not necessarily the case, though. It may well depend on changes to AppleScript in 2.1 too, or changes to the Cocoa framework.

Good luck, but I don't fancy your chances.


Shane Stanley <sstanley@myriad-com.com.au>
www.macosxautomation.com/applescript/apps/

Offline

 

Board footer

Powered by FluxBB

RSS (new topics) RSS (active topics)