panther Internet Connect -problem

I tested your suggestions and had no success getting them to work in Panther. Panther changed a lot of stuff in AppleScript!

That strikes me as odd since it’s very basic AppleScript code.

– Rob

But Rob, you seem to be missing the whole point of this thread. There have been scripts that have worked for many of us in the past. The script that I used to use with each of those programs I like to open at start-up; Internet Connect, Mail, etc, I copied directly from someone else’s post. However, upgrading to Panther broke it. I couldn’t get hardly any of the individual pieces to work. What has been basic scripting in the past has been changed, by Apple Computer, and will require some relearning. Or in my case, because I am just now learning AppleScript, I will be learning things that acomplish for me in Panther what I need and it will perhaps be different than the way you can acomplish it in Jaguar.

It is not rude, just true, someone’s suggestions about how to accomplish something in 10.2.x is likely not going to be useful to someone working in 10.3.x. And the Jaguar person won’t understand it until they upgrade and see for themself. Then like me they can wander Apple’s AppleScript website and find out the changes they have made and the new way to do things.

Thanks for trying to help.

I tested Rob’s code in Mac OS X 10.3.2 using Mail 1.3.3 (v612) and NNW 1.0.8 and it worked flawlessly. While there have been changes in AppleScript from 10.2.x to 10.3.x, in many cases the changes require no modifications to scripts (especially when scripting third-party applications that haven’t changed) or very minor tweaks, not major reworking. Rob is correct that very basic code like this (and it is very basic) has not changed.


Sorry, I copied it directly from the webpage, dropped it in place of my previous code, it compiled and then I got continual error messages every time I ran the script.

This will be my last post to this page. I posted to offer info to the guys who were having trouble with Internet Connect. I had the same problem and solved it.

I’m not interested in a battle of any kind.

I’m curious, what is it in my post (or Rob’s) that seems antagonistic to you? I assure you, there is no battle going on here, just a conversation with suggestions from strangers on how to make things easier.

Thank you for posting your code to help others, try to take the help Rob posted (and I corroborated) in the same spirit.



I’m positive that no one is trying to start a battle. We spend hundreds of hours every year trying to help the visitors of these forums, so there’s little time for battles or foolishness. It seems that there must be a problem that’s preventing simple code from working on your setup (and on other computers as well). If we can determine what the problem is, it will be helpful to you and the others. In the end, finding a solution is beneficial to all of us.

Sometimes when I get unexpected results/errors from simple scripts that should not fail (which happened about an hour ago), I reboot my computer and the problem disappears. Other problems can sometimes be eliminated by repairing permissions. Finally, on the extreme end of troubleshooting, a reinstall of the OS seems to fix some issues.

One issue that can cause problems is that Safari sometimes butchers code when copying and pasting. It’s sometimes necessary to inspect the code closely and tweak as needed.

If you don’t wish to participate, that’s your call, but it seems that you might benefit by doing so.

– Rob

Thank you for this. It works fine in my OS10.2. Would you know how to embed it with an error handler to deal with a connection failure dialogue box?