Anyone can tell what's wrong with my script?

Hi, I wrote a long script for Apple Automation, what it does is it install bunch of utilities from cd, and uninstall them. The script itself works perfectly (Runs 15 min in average system).

The problem is, the script can almost never run from the begining to the end, it always stuck in the middle somewhere (usually after halfway), somewhere it can’t click a button (even when the button is there). But if I restart the script and tell it to run from where it failed (say I have to install utilities 1-10, if it failed on No. 6 utility I could just restart script and tell it to run from utility 6-10), it always works(means the script for click button is working, it just always failed on the long run somewhere)

I been trying to solve this problem in the past couple of days, still can’t. It seems to get stuck earlier on slower machines, but on fast machine it still happened at least once per run(around 60% of the wholescript, the place it happens always around button clicking). I wonder if there’s a memory issue with my script?

If anyone can help plz post here. Thx BTW i use PreFab player for button clicking and i have mac os 9

Have you tried increasing its memory allocation?

Problem solved, thx! :slight_smile:

Just curious. Solved by increasing the mem allocation, or in some other way?

Solved by increasing the memeory allocation.