Applescript - Accessibility and Mavericks


I have a script that use the accessibility features to simulate clicking in specific menus and windows.

With Mavericks, I have a problem, due to change in OSX and new restrictions (understood after some searching on internet).

I found this article in Apple’ kb :

But when I run the command given in this article (codesign -s - --resource-rules=/Users/YourUserNameHere/ResourceRules-ignoring-Scripts.plist /path/to/ :

  • I had to adapt the command to use YourUserNameHere/Library/Preferences
  • If I run the applet, I still get the error message telling me that my applet is not authorized to accessibility access

Any idea ?

Also it seems that you can sign your applet from applescript editor, using the drawer button “bundle contents”, but I have no developer account, and cannot access to this drawer button.

Thanks for your help,
Best regards,


I found a solution : save the script as a bundle, then the drawer is available. Then I saved the script as an application.
In addition to use the terminal command, and declaring the app in the accessibility pane of the preference panel.

I don’t know if I made too many things… but it works,


I’ve run into this same problem. I can run my script from the AppleScript Editor just fine but when I save it as an app, I get the error. I’ve tried to do what the article directs, but that didn’t work. I don’t understand your comment about making it a bundle. Can you explain a little more?