AppleScript app Assistive access trouble

I have saved an apple script as an app and when I launch it I get the following error

System Events got an error: DualFinder is not allowed assistive access. (-1719)

I have given the app accessability permission in system settings but still recieve this error any ideas

It runs fine from the script editor but the final project needs to be a stay open app

tell application "System Events"
	tell application "Mission Control" to launch
	tell group 2 of group 1 of group 1 of process "Dock"
		click (every button whose value of attribute "AXDescription" is "add desktop")
		tell list 1
			set countSpaces to count of buttons
			delay 0.5
			click button (countSpaces)
		end tell
	end tell
end tell

DualFinder is the name of your script application as I understand. So,

  1. First, clean your script:

tell application "Mission Control" to launch

tell application "System Events" to tell group 2 of group 1 of group 1 of process "Dock"
	click (every button whose value of attribute "AXDescription" is "add desktop")
	delay 0.5
	click last button of list 1
end tell
  1. Save it as usual application (not stay-open)
  2. Launch it, give to it permission to control your computer. Go System Preferences–>Security&Privacy----> Accessibility. See: if the checkbox is checked (and application throws error) , then uncheck it and check again. If it is unchecked then simply check it.
  3. If this doesn’t help, then remove from the list using MINUS button, then go step 3) again .

The probable reason for this is the ‘countSpaces’ variable, which, being a run handler variable (ie. used in the top level of the script), is saved back to the script file every time the script’s run. This changes the file’s modification date and the security system thinks it’s a new file.

KniazidisR’s suggestion gets rid of the variable.

I found the best way to avoid this error is to use + sign and add application that way first.
Then try run it. (I.e don’t try run it first. I.e. don’t drag and drop in there first.)

As a last resort fix: open system preferences. Remove the app with minus. Lock. Quit system preferences. Reopen system preferences. Add app with plus sign. Lock. Quit system preferences. Then try run app. Take your time with each of these steps…don’t rush it. Still not working. You can mix in a restart and some log out log ins…it will eventually work…sounds like madness I know…but it works.

Monterey 12.4.

There’s some info on the bugginess of this whole thing here:

But I’ve found my method at the top the most reliable…and now just do it that way to begin with.