Applescript Application Bundle built on 10.3 incompatible with 10.2

I tried making a simple Applescript on OS X 10.3 Panther (AppleScript 1.9.3) and saving as an Application Bundle (I tried both through Script Editor 2.0 (v43.1) as well as through osacompile), but unfortunately, neither Application Bundle will work correctly on a machine running 10.2 Jaguar. When I double click the file, I get the following error:

‘Could not run the script “applet” because of a program error. -1376’

This is on a machine running Mac OS X 10.2.4. If I save the same script as an Application in Script Editor (it seems osacompile cannot make non-bundled Applescript Applications - please someone correct me if I’m wrong), it works fine on the 10.2 machine. If anyone has any suggestions on how I can get an Application Bundle-based applescript to work on 10.2.x please let me know! (or if anyone knows how to build a non-application bundle-based Applescript through osacompile, that would work as well). Thanks in advance!


You will be pleased to know that applescript went through major changes from 10.2 - 10.3 . 10.3 does many, many things 10.2 doesn’t. However, most scripts written in 10.3 won’t work in 10.2 The syntax changed so much that the computer doesn’t understand it. If your script does anything with non-script-aware apps, such as “click” commands, anything to do with the user interface or any of the other 30 odd commands that aren’t in 10.2, then i guess you’re just out of luck. Sorry I’m having the same problem for 2 months now decided only thing to do is upgrade.