AppleScript look weird in text editors

I am trying to edit multiple apple scripts and the most suitable (and for me simple) suggestion is to open them in a script editor. However when I do this the script is unreadable to me with many weird characters and only the odd glimpse of a few recognisable words. This is the same for all scripts even the ones that come in the AppleScript Editor samples folder and doesn’t matter whether they’ve been written in 10.6.8 or a later OS X.

I have tried this using OS X from 10.6.8 through to Yosemite, and tried subethsedit, text wrangler and text edit.

I’m sure I’m doing something stupid any help would be welcome.


Apparently you are trying to open a compiled version of your scripts. Open the scripts in a script editor i.e. Script Editor, Script Debugger or Smile and re-save them as text files.

If a script has any file extension except .applescript (text file) then it is saved as bitecode not text and will look like gibberish when opened in a ext editor.

Model: iMac
AppleScript: 2.5
Browser: Safari 601.5.17
Operating System: Other