ApplescriptObjC Explored Example

Hi All,

I’ve started teaching myself a bit of Applescript and have been lured into AppleScriptObjC to avoid the never ending dialog boxes for variable entry. I’ve been reading ApplescriptObjC Explored, which is really informative.

However(!) In the first example I struggled to link the “process” button and realised that my AppDelegate was was labeled “App Delegate” rather than “Making Progress App Delegate” (like in the demo project). I worked out that changing the first line to

script AppDelegate

fixed my problem, but wonder If i’ve setup wrong or if this is a subtle difference of the XCode I’m using? I’ve tried creating other projects (with other unique names) and each come with an “App Delegate” rather than a “project name app delegate” as it looks like it should be.

Are there any benefits/problems I could have with this?

I’m on Xcode 4.2 Lion 10.7.2

I appreciate this is a very basic questions, but I’m trying get a good understanding of what I’m doing rather than just copy and pasting code…



I’m afraid that I don’t know the answer to this problem, but It’s happened at least once to me in Xcode 3 as well. I don’t know what I may have done differently in that project, but I think it was the only time in 200 projects using Xcode 3 under both Snow Leopard and Lion.


Thanks for the quick response!

I’ve created 3-4 other new projects, and all are performing the same. I’m hoping someone might be able to show me the error in my ways!


The difference between ProjectName_AppDelegate and simply AppDelegate is a change Apple made with Xcode 4. You don’t need to change anything (and you have to be careful if you do) – just use what’s provided.

The name just has to be unique for the particular project, so using the project name was deemed unnecessary.

Thats great. Good to know I’ve not got it wrong.

Awesome work with the ebook, its breaking ASOC down in to very manageable bits.