Arc errors upgrading to Xcode 6.1

Hi All,

Just upgraded to 6.1 and my code is throwing 20+ errors all “ARC semantic issue … no known instance method for selector…”

This is in an OBJc class which previously called methods in app delegate (applescript class) just fine

[[NSApp delegate] reloadMenuNow:arr];

Any thoughts?

Thanks, Rob

Recent versions of the compiler are much fussier. You need to specify casts like this:

[(AppDelegate *)[NSApp delegate] reloadMenuNow:arr];

Interesting… it really doesn’t like this though. getting “expected expression”, “undeclared identifier” , “expected ]” !

Saw another post where this worked:

id apDel = [NSApp delegate];
[ apDel reloadMenuNow:arr];

and it does!

But they said the cast worked too though that was in an OBJc app with OBJc app delegate.

Cheers, Rob

Is that the correct name for the app delegate? Do you have an #import statement for it?

it’s called “backupCAppDelegate.applescript”

how do you import that?

#import “backupCAppDelegate” won’t compile

oddly though the errors went away so it is doing something… the (backupCAppDelegate*) seems to be recognized now


Sorry – you probably want:

@class backupCAppDelegate