ASS app runs on 10.3.3 but not 10.2

I’m developint AppleScript Application on Xcode running on MacOSX 10.3.3.
I found that some application have problem on OS 10.2 though it work fine on 10.3.

I created a simple application which has several button s and text fields and WebView.
When I just add all UI components and build the project, compiled application worked on both 10.2 and 10.3.
But, after turning on some event handlers on IB info view, in AppleScript section, compiled application work only on 10.3. On 10.2 I got ‘Segmentation Fault’ before window is opning (I tried it from Terminal).

Is it possible to develop AppleScript Applicaiton on Xcode which can run on both 10.2 and 10.3 ?


Is it possible to post your project files, any code, or at least the compiled application?


I put my project on
To reduce the size of the archive, I cleaned any objects. So, please try to build it.

This project should be compiled successfully and runs on both 10.2 and 10.3.
But in my environment, adding AppleScript Event Handlers cause problem (Segmentation Fault) on 10.2 system.

  • open Japanese (OK it doesn’t contain any Japanese yet) Nib file
  • click on rewind button on left most
  • press Command + Shift + I and open information panel
  • select AppleScript
  • check ‘Action → on clicked’ and check ‘OtologController.applescript’
  • save Nib file
  • build the project

—> after that, launch application on both 10.2 and 10.3. the application can be launched on 10.3 but on 10.2 it can’t be launched. I also tried to launch it from command line on Terminal app and saw “Segmentation Fault” error message.

Could you please give me some advice? [/b][/url]