Automate Final Cut Pro Compressor Droplet

I would like to write a script which would do this:

  1. Watch a folder
  2. If a new mov appears, starts a Final cut Compresor droplet with this video as the argument (is this possible at all???).
    It must act as if a user had dropped this .mov onto the Final cut droplet… Everything else would be handled by the droplet, when once startet…

Any idea?

The other way would be to let Apple Script start a Final Cut Compressor and manage its settings, but that seems to me much more complicated (if doable at all) than activating this droplet via Applascript… :slight_smile:



Hi Ute,

have you searched the board for “compressor”. There are a couple of threads at this issue

No, I searched for Final Cut and didn’t find anything which even was related to my problem:-)

Thanks for the tipp!

Ok, I tried the suggestions, but cannot get them to work… I have installed the newest Compressor of Final Cut… perhaps this makes a difference, perhaps not…

I tried this:

tell application "Finder"
open file "" using application file ""
end tell

I get this error when I try to execute the script:
File kann nicht gelesen werden

I can drag that very file by hand on the very droplet and the file is processed without any problems…
The File can be found under the path. The Droplet can be found under the path…

Any idea?

I’ve never tried open file using application like that with AS however I do use a similar method for my Acrobat Preflight droplets and they’ve been working just fine. The basis of what I use is in this.

set The_Application to choose file with prompt "Where is the application droplet?"
set The_File to choose file with prompt "Where is the movie file?"

my Open_With(The_Application, The_File)

on Open_With(The_Application, The_File)
		do shell script "open -a" & space & (quoted form of (POSIX path of The_Application)) & space & (quoted form of (POSIX path of The_File))
	on error Error_Message
		-- display dialog Error_Message
		return false
	end try
end Open_With

Whatever I do I get the response from the Compressor:

Cannot open file.

The rights are ok (everybody can do everything)

Whatmore, I tried th use the shell script and tried to open the file with it directly from the shell and got back cannot open file…

Has the droplet to be in the folder with the quicktime movies/on the same machine/the same volume … any such restrictions known?