Automating timed unattended backup and shutdown

I run a small design studio with 3 networked Macs running Panther. There ought to be a way do do what I want using Applescript, but I am also an Applescript idiot.
All Macs are running Retrospect Desktop 6, as well as Belkin Bulldog 3.0.2 UPS software and Belkin Universal UPS 1200s. 3 users share the Macs.
I have been trying (with only occasional success) to automate at the end of the day a scheduled Retrospect backup, followed by a scheduled OS and UPS shutdown using Bulldog. This must take place with no one logged in.
Retrospect backs up every time, but the Macs and UPS are usually still on the next morning. When I launch Bulldog the next morning, Bulldog has lost USB communication with the UPS.
Occasionally, one of the 3 Macs/UPS will shutdown, but mostly not.
I believe that Bulldog loses USB communication after being idle for a while, so I have tried the following:
Energy Saver set to defer sleep for 3 hours
Retrospect backs up at 5pm
Bulldog shuts down the OS and UPS at 6pm

According to the log, Retrospect is not interfering with the timed shutdown, completing the backup well before 6pm.
Retropect can also run a script upon completion of the backup.
I would like to try an Applescript launched by Retrospct that uses Bulldog to perform an immediate OS/UPS shutdown as soon as the backup completes.
Anyone have an ideas?

Is the Bulldog software scriptable? Do you know how to find that out? Ask if you don’t. I couldn’t find a copy online, but the reviews I saw suggest that the software has a non-standard interface. If that’s the case, you’re probably out-of-luck. It probably doesn’t have a dictionary, and scripting it through the Universal Access interface has serious problems for applications that don’t use the standard OS APIs.

Thanks Michael. No, I couldn’t open the Bulldog app with applescript. For the time being, I’m just ending the Retrospect backup with a restart, and timing the OS/UPS shutdown as close as possible to the end of the backup. It seems that in Panther, Bulldog loses communication with the UPS over USB. A restart seems to fix it temporarily.