Basic basic stuff…

Hey guys, I’m a total newb to this forum, applescript, and scripting in general, so please bear with me!!

I’m trying to write a teeny weeny script that launches Toast 6 Titanium, loads a CD image, then mounts that image. However, i’m running across a problem:

tell application "Toast 6 Titanium"
	open "CD1.dmg"
	mount image
end tell

Even if I type in the entire hierarchy to the file, I still get the same error: “Toast 6 Titanium got an error: Can’t make some data into the expected type.”

Can anyone point out what I’m doing wrong? It’s probably something really stupid.

Model: PowerMac G5
Browser: Safari 416.13
Operating System: Mac OS X (10.4)

The text set off by quotes denotes a string (class of object) in AppleScript. A string can’t be “opened” and AS is telling you that it’s a nonsensical command.

An application can, however, open a file (class of object), so coerce your string to a file name:

open file “CD1.dmg”

Regrettably, this probably won’t work, though, because you haven’t written a full file name string.