Batch Printing QuarkXpress files


Since OSX doesn’t have a batch print command the way OS9 did, I’m working on a script to attach to a folder action to do the same thing.

I haven’t started working on parsing the names of the files in the folder because I’ve run into a problem.

If I type in Script Debugger:

tell application “QuarkXpress 4.11”
tell document 1
end tell
end tell

the script hangs up on the “print” command. If I generate it out as a Classic Application, it prints fine.

Has anyone run into this? I need to get the files to print in Compiled Script format and not as a Classic App to attach properly to the folder. Until I can get this functionality working, it makes no sense coding the rest of the folder action.



It’s a known problem, but there’s a work-around.

Check this out…

Many thanks.

I’ll give it a whirl today.



I gave your solution a try (writing a stay open, never show startup screen classic app which tells Quark to print the file & close the document – and which in turn is called by an OSX script from Finder).

It worked once on the first file (or iteration as I ran the test as a repeat loop) but then died on subsequent passes.

I think it has something to do with the strange behavior I notice in Quark 4.11 running on my OSX 10.3.2. When I sometimes launch Quark files the document opens but the document window is dim and the tools don’t appear. I need to touch the cursor into Finder and then back to the document to get everything working right. When my script dies, the file is in the mode just described.

Has anyone else noticed this behavior? Does it screw up scripts? Is there a workaround? (Jeez, I can’t wait to we move to InDesign CS and go OSX native).


To test your theory, maybe you could refer to the document window by name instead of by level (i.e. “docname.qxd” instead of “document 1”)?

Check out this thread… it sounds pretty close to your problem?

Posted: Tue Jan 20, 2004 4:27 pm Post subject: HELP, script won’t print Multiple Quark docs from OSX Finder