Brand New Newbie with bad luck. Please help!

I love making the simplest little applescripts and I have been doing so for a while here in OSX. Now on 10.3.1. They run fine in my OS on my machine but when I send them to a friend they won’t work. I tried running them on (my machine again) 10.2.6 and only two out of three worked.

What’s this about? These are real simple scripts:

set stringtobedisplayed to “How about Dinner?”
display dialog stringtobedisplayed buttons {“Sure”, “Maybe”, “I’m feeling Lucky”} default button 3

Am I missing something that these won’t work on another machine? And only sometimes in the last OS?

Thanks very very much for helping me get off the ground here!

On earlier versions, you had to include the application that had to handle the action item.

What if you “wrap” your commands in a:

Tell application “Finder”

end Tell

In fact I did do just that. It seems the big problem was that I was using a cheap-o zip program for compression. With stuffit I’ve had better luck already. I hope that’s the only problem. I’m waiting for some tests to come back.