call SOAP error 'No such operation'

I’m trying to use AS to retrieve patent data from a European Patent Office web service. The call soap command in the script below, however, returns a ‘No such operation’ error, even though the method name appears to be correct. Here’s the script:

set serviceurl to ""
set methodname to "getPatentData"
set namespace to "urn:EPO-OpenPatentServices"
set searchtype to "Biblio"
set querystring to {|SEED|:" US     4000034A#", |SEED_FORMAT|:"D", |SEED_TYPE|:"PN"}
	using terms from application ""
		tell application serviceurl
			set xmlresponse to call soap {method name:methodname, method namespace uri:namespace, parameters:querystring, SOAPAction:searchtype}
		end tell
	end using terms from
	return xmlresponse
on error errmesg
	display dialog errmesg
end try

The service is confirmed to be working with the generic soap client at, which also confirms the method name and service address.
The web service is described at at
General input XML schema is at
WSDL for the service is at
Method name “getPatentData” is confirmed by WSDL Analyzer tool at

But the script gives an error: No such operation ‘getPatentData’, so I can’t get any data back at all.

If anyone can help figure this out, I’d appreciate it!


I was trying to do exactly the same thing, and after searching the internet I found your post about retrieving european patent information.
I tried your script and I get the same error message.
However, I am a newbie with SOAP and I don’t understang why you were using “” in the following part of your script:

I replaced it to look like that:

	using terms from application ""

but I now get a “Transport Error” message.

Actually, I think our problem would be solved if we were able to translate the xml example given in the Open Patent Services pdf description document into an AS script. This xml example is copied below:

<?xml version="1.0" encoding="UTF-8"?>


Thanks for any advice from SOAP and XML geeks!