Can't copy large amounts of data

Whenever I try to copy a folder larger than 1.8 GB from one drive to another or even to another location on the same drive using the Mac OS 9 system on my G4, the finder crashes. I’ve talked to Apple’s “genius bar” people about the problem but they always skirt around the issue and basically give me a talk on how I should stop using OS 9. The problem persists on OS version 9 through 9.2.2. I like to use OS 9 to copy stuff because it’s the only way to keep the file info comments on both OS 9 and OS X when copying files and folders.

Do any of you script writers know why Mac OS 9 has this problem and/or a way around it using scripting?

Is Mac OS 9 just not capable of copying really large chunks of data at a time?

I can’t get any answers from Apple. I already tried upgrading to the latest version of OS 9 and then tried reinstalling OS 9 from the OS 9 disk, at Apple’s suggestion. None of those solutions solved the problem.

I’ve gotten answers before on this board when I hit a “dead end” at Apple. If anyone is familiar with this problem and has found answers through scripting (or otherwise) please let me know.


“Doctor, it hurts when I move my arm like this.”
“Umm… don’t move your arm like that.”


I don’t have the means right now to test this with a really large folder, but give this a shot:

set copyFrom to choose folder with prompt "Copy This Folder..."
set copyTo to choose folder with prompt "...To This Location"
tell application "Finder"
	set copyName to name of copyFrom
	set copyMirror to make new folder at copyTo with properties {name:copyName}
	set copyItems to every item of copyFrom as alias list
	repeat with i from 1 to copyItems's length
		duplicate (copyItems's item i) to copyMirror
	end repeat
end tell