can't open dictionary


I have decided i would like to learn more about applescripting, so with some time one day sat down and had a look around script editor 2 on my powerbook g4 1.25

i opened up scripts read them, etc i also read the help file, which mentioned doctionaries.

Now comes the problem, i went to open dictionary, a full list of apps appeared. i click on address book and the app opened behind script editor, but then script editor disappeared and i got the “unexpectedly quit” window

i have tried differnet apps from the open dictionary list.

i have tried dragging the apps onto the application icon and the same.

any ideas please.

i have also repair permissions, restarted, and even download 2beta and removed it again. have delete pref files.

i am stuck, if you know anything i can try i would like to know so i can start to learn more.

many thanks



For some reason the Script Editor beta kept quitting on me right off the bat over and over again. Anyway, I dumped it. It seems to work on the computer of others but not mine. Sounds like the same thing but you’re running Panther.


hi kel

thank you, sorry you had trouble too.

i am on panther, i installed the beta by mistake, i thought i was on script editor 1.9.3 when that is applescript 1.9.3 pather comes with script editor 2 installed

either way they both still quit on me.

i am just hoping i don’t have to reinstall everything, booo



seems like if you’re running Panther then don’t install the beta System Events. Damn I can’t think right now but if you’re running Panther then you should get the updated AppleScript. Now I’m stuck in nowhere land but somehow you gotta get there. not nowhere land but the updated AppleScript


You said that you tried to install the Script Editor 2.0 beta. Now, after intalling the beta, did you then reinstall the Script Editor that came with Panther (using something like Pacifist)?

If you didn’t, then that should probably be your next step. If you’ve never used Pacifist and need some help figuring it out, post your questions here and we’ll walk you through it :slight_smile:

Of course, whether or not this works is dependent on what exactly gets installed by the Beta installer, I’m hoping it was just the Editor, and I think it is since you still have Applescript 1.9.3 installed (which is what I’ve got as well).

Good luck.