Choose File dialog with folder alias (symbolic link not working

Ok, in Snow Leopard Applescript, if I use a "choose fil"e applescript command, and, in navigating to the file I want I click on a symbolic link (or alias) of a FOLDER, the choose file dialog keeps going so I can pick the file I want.

In Lion, when I double click the symbolic link (alias), it picks that file, even though that points to a folder. So, it seems to be counting the symbolic link as a FILE, not a folder. This is different than what snow leopard did.

While I can certainly navigate to the file without the symbolic link, it’s often a very long file path. Is there Applescript that can get around this, or, is that just the way it is in Lion?


you write

I just tried on my Lion, and symbolic links did not behave like aliases. in a choose file dialog, an alias (which uses a very different technology) behaved like it did under Snow Leopard. I just could navigate through it like before.

A symbolic link (created with ln -s in the Terminal app) was actually handled like a file in the choose file dialog. It was resolved (the returned alias of the dialog pointed to the folder, the symbolic link pointed to), but I could not navigate through it.

So currently, you probably need to use aliases rather than symbolic links. Still, the behavior looks much like a bug.


What’s even stranger is that it works differently for me if I run from a built app, vs, running from within Applescript Editor. From an built app, it works fine. Must be a bug.