Clean (re)install of AS - Snow Leopard

As AS does not seem to work and I cannot find various parts in my system (Scripting Additions, Standard Additions,…) since Snow Leopard, I believe I need to reinstall the whole AS.

Is there a way to (clean) reinstall AS, without reinstalling the whole OS?



MacBook Pro OS: 10.6.1 - AS: 2.1 - SE: 2.3

Thanks Tom.

I did reinstall the System and I think I now have everything in the right place. Yet when I run this simple script from the release notes:

 set theBootVolume to path to startup disk
 tell application "Finder"
 end tell

I get the following message.

error “startup disk doesn’t understand the path to message.” number -1708 from startup disk

Still, something is not right!

I repaired the permissions and apparently no conflict with old osaxen, which I have set aside. Could it be that I need Rosetta to use Standard Additions?


The error message says, that Standard Additions couldn’t be found.

Yet, StandardAdditions.osax

(1) is installed in System/Librayy/ScriptingAdditions
(2) I have read/write permission (in Get Info)
(3) is showing in the Windows/Library Menu of ScriptEditor.

I have checked the HD and it is fine. I have a clean system and none of the third-party utilities mentioned by Tom.



I just created a new test account and it worked!

Of course, back to the original admin account …

So, we are getting somewhere! What is the next step?



Thanks Tom,

Did that but, unfortunately, it does not work yet!



It worked on the second run. It needed a deep cleaning, I guess. LOL

Thanks a lot. I depend so much on AS!