Convert ASS interface to ASOC

I’m trying to recreate a ASS project to an ASOC one. The ASS project had quite an elaborate interface that I don’t want to recreate from scratch. What would be the best way to do that? So far I’ve tried by dragging and dropping interface elements over between both .xib files but the result is that I get these error messages in my console:

which I assume has to do with the AppKitScripting.framework being absent. What’s the way to get rid of those pesky errors?


I guess you must remove all names and connections in the AppleScript tab

Hi Stefan, thanks. I did that. But it kept giving me errors. It looked like some interface elements stubbornly must have held on to some information. I tried unticking all checkboxes under “Event Handlers”, but some elements kept showing the minus sign for “mixed state”. After deleting those interface elements, everything worked fine. I have lost a few parts of my original interface, but most of it is still there.

Open the original ASS project and remove all names and connections.
Then copy the UI element into the new ASOC project

I tried it and it still failed. I have managed to bring it down to one combo box that creates the error every time despite there not being a name or any connection. I remember that part of the interface going though a lot of iterations in its early design stages, so things may have gotten a bit corrupted, who knows.

Replacing the old combo box with a new one is straightforward enough so I’ll leave it at that. Thanks for your help.