Creating Dialogs in InDesign CS6

Moments after I posted this I realized…

I bet I need to put in:

set user interaction level of script preferences to interact with all

Guess what works now? :frowning:

I will leave this post just to see if anyone can help with the arguments thing.

Yesterday came in and we have been upgraded from 10.5 to 10.8 and CS5.5 to CS6.

I had written scripts to make my life easier, but none of them work now. 

First off I have NEVER been able to get a GUI to show up in InDesign written in Applescript, so I have a Javascript to do that and it hands off the stuff to the applescript like so:

myParameters = [Name,Body,Adnumber,Color,Banner,Bulleted,Address,Type];
myAppleScript = new File("/Volumes/Scripts/");
app.doScript(myAppleScript, ScriptLanguage.applescriptLanguage, myParameters);

This calls the Applescript. It worked before the update. Currently it does call the applescript, but the arguments do not seem to handed to the Applescript:

set Agent to item 1 of arguments

Something like this simply says arguments is not defined.

Using the code:

on run arguments
		set mytest to (arguments as string)
		display dialog mytest
end run


returns the "Current Application" thing.

[i]It would just a WHOLE lot easier if it was all in Applescript, for me anyway.[/i]

The following is from the Guide on Scripting CS6:

tell application "Adobe InDesign CS6"
  set myDialog to make dialog
  tell myDialog
  set name to "Simple User Interface Example Script"
  set myDialogColumn to make dialog column
  tell myDialogColumn
  --Create a text entry field.
  set myTextEditField to make text editbox with properties {edit contents:"Hello World!", min width:180}
  --Create a number (real) entry field
  set myPointSizeField to make measurement editbox with properties {edit value:72, edit units:points}
  end tell
  end tell
  set myResult to show myDialog
end tell

Nothing happens at all other than false being returned by the script. I have searched and found many examples of this sort of thing being used, but no mention of it not working....

So anyone have any ideas either way? I just need to get this stuff working again.

AppleScript: 2.2.4
Browser: Safari 537.36
Operating System: Mac OS X (10.8)