Curious QXP/FileMaker Pro Script Problem

Forgive me if this explanation gets a little long. I am creating a system of scripts/FaceSpan apps (MacOS 9.1) that all work well independently, but two of them create a curious problem when run one after the other. The first is a script using FileMaker Pro/AS/QuarkXPress to create a catalog. The second converts QuarkXPress docs to EPS,PDF, JPEG or TIFF (this is a FaceSpan app). If I run the second one described, immediately after the first, the cursor wheel turns but nothing happens. If I type command - period, the script moves on as it should, but when the QXP doc prints to the EPS file, I get a postscript error of type (-Fourty Eight). Oddly, however, if I wait a few minutes and try again, it works fine. I have isolate one problem being with Desktop Printer Manager but put in a timeout and alternate approach that bypasses that problem. Another curious problem is with FileMaker Pro. It uses a “Perform AppleScript” script in ScriptMaker which when I first open the Database and run the script, creates the QXP document, but it doesn’t create the page items in QXP. If I open the script in ScriptMaker and close it, it runs perfectly. I’m at a loss. I’ve been working on debugging this for several days with no breaks.

The only thing I can think of is when I tried to use an applescript that worked well in script editor and wouldn’t run in FMP. The problem I was having was I was making calls to FMP and when embeded in FMP it had problems with those calls. I needed to change the script and take out the “tell application FMP” lines. Things worked much better after that.

I hope this makes some sense and good luck!