Database Events


Yosemite has seemed to change Database Events. You now have to create the location of the database when you create it

set x to choose folder
Tell application "Database Events"
	set theDatabase to make new database with properties {name:"AppointmentData", location:x}

Any how i populated the database with some records and performed a find which all worked fine.

After working at a script I tried to perform a find and it would not find a field

These errors

tell application “Database Events”
open database “/Users/johnclark/Documents/AppointmentsData/AppointmentData.dbev”
get record 1 of database “AppointmentData” whose value of field “email” contains “
error “Database Events got an error: Can’t get field "email".” number -1728 from field “email”

If I run a properties command it returns
{store type:stop, class:database, location:file “Whopper:Users:johnclark:Documents:AppointmentsData:”, name:“AppointmentData”}

the location of the file does not look right. Strange that it needs a POSIX file path to open and location returns HFS
The database is open but not responding.

Any ideas