DEVONthink Pro Office (DTPO): using the "add row" command

In DEVONthink Pro Office, a record in the global Inbox is a sheet.
I want to add a row to the sheet. Unfortunately, this does not work:

tell application "DEVONthink Pro"
	tell database "Inbox"
		set c to content 2
		set k to add row c
	end tell
end tell

While c has class “record” and type “sheet”, it does not recognize the “add row” command.
I have tried referring to the record as to a “content”, a “record” and a “child”, but it does not help.
I have also tried to use various properties as the reference of the command (for example, set k to add row cells of c) but nothing worked.

Obviously, I misunderstand the “add row” command. More specifically, I don’t know what type of reference to use.
Any help in that area will be greatly appreciated. Thanks in advance! W.

Did you see this? A quick look at the mentioned script suggests you need to tell a window displaying the sheet, not the sheet’s record.

Yes, thank you. Something like this does work:

tell application id "DNtp"
	tell think window 1
			add row			
	end tell
end tell