Dialog Director not working on startup CD

Hello All,
I created a startup CD that launches my script automatically. The problem is that the script does not recognize the DD commands in the script additions folder. The really funny thing is that it has worked in the past. But I don’t know what I have done to change things.
Does anyone have any suggestions?
Thank you in advance.

The most likely answer is that there is a component missing (or corrupted, perhaps during the transfer), so the obvious first step must be to painstakingly go through the System Folder on the CD to spot what it is - or, perhaps simpler, to copy the Sys f from your startup disk (or disk you use when Applescripting) to the CD. If you have the DD osax in the correct folder then you must suspect that it is something else altogether that is missing.
When you say it worked before what do you mean? From the CD? Or from your hard disk?
I presume that we can take it as read that you don’t have anything that needs to be written to , e.g. a property.