Enable UI scripting in OSX 10.9 Mavericks

Recently upgraded to Mavericks, and found that my scripts to activate UI scripting no longer work.
It appears that Apple have changed the way UI scripting is activated, can anyone tell me how to
set this up in System Pref’s or with a script.

Many Thanks in advance.

Regards Mark

Hi Mark,

Go to System Preferences > Security & Privileges. They changed it so that you need to allow Apps to accessibility features…


OK Thanks kel

I’ll have a look at that now.

Regards Mark

I suppose that means that the code below no longer works ?

tell application "System Events"
	set UIenabled to UI elements enabled
	if UIenabled = false then
		set UI elements enabled to true
	else if UIenabled = true then
		set UI elements enabled to false
	end if
end tell

Regards Mark

Found this info on Shanes site for anyone encountering the same problems.



Just a clarification: that’s not my site (it belongs to Sal Soghoian). I’m just a tenant there…

Sorry my mistake Shane, I did’nt realise that it was’nt you site.

Regards Mark