Error in script after upgrade to Yosemite

Hope someone can shed some light on this issue.

After upgrading to FileMaker 13 (from v 12) and to Yosemite (from 10.6.8) this line stopped working:
Within a long tell application “Microsoft Word” statement…

save as active document file format format PDF file name pdfsavename

ScriptEditor says “Expected an end of line but found an identifier” (loosely translated from swedish)

It also stopped at this line

print active document with properties {target printer:"CanonMP810Feed"}

saying “Expected given, with, without, other parameter name but found {”.
It consequently stops at all such lines.

What happened? Can I fix this? Have I written something wrong from the beginning? Everything worked fine before updating.

After a few days of searching and trying I have come up with a solution. I publish my results here for the benefit of others:

First try:
Could it be something wrong after the upgrade with the LaunchServices? Some google-posts indicated towards that.
I downloaded OnyX to rebuild it. It didn’t solve the issue.

Second try:
Tried to repair permissions using DiskUtility. Problems were found and fixed but it didn’t solve the issue.

Third try:
Tried to repair the disk by booting with command-r and problems were found and fixed but it didn’t solve the issue.

Fourth try:
Un-installed MS Office 2011.
Re-installed it, updating it with all downloadable updates.
It solved the issue! Now all scripts works fine!

Kind regards
The Swede