Error: NSReceiverEvaluationScriptError; 4 (1)

I was trying to make an Automator plugin action that would save a file in a particular format for use with Sound Studio 3. The plugin does what it’s supposed to do but when it’s finished it throws up the Applescript error “NSReceiverEvaluationScriptError; 4 (1)”

I googled the error and came up with a forum posting that said it was the result of a SIMBL plugin. The poster said that he removed the plugin and everything was fine. So, I did a Spotlight search and discovered that I had that plugin on my laptop. I dragged it from the library and deposited it on my desktop and restarted my machine. Then I tried the automator plugin and it seemed to work just fine without an error dialog. So, I concluded that the SIMBL plugin was the problem.

I then tried using the Automator plugin some more to convert some Sound Studio files to a different format and the very first file I tried gave me the error message. Every file after that did the same. It appears that the Automator plugin is doing what it’s supposed to do (except that the dialog interrupts the flow) but I still come up with that NSReceiverEvaluationScriptError; 4 (1) message.

Any ideas?


I really dislike those “NSReceiverEvaluationScriptError” errors. For me they’ve been just like the old “Syntax error” or the Mac’s “unexpectedly quit” errors…interesting notifications, but not terribly useful for debugging. :frowning:

I’ve found this error is usually set-off by some kind of syntax problem. Maybe a file name that is an alias instead of Unicode or the other way around (which will cause file functions to work on some, not on others), or when UI scripting it’s cause by try to execute a command before the application is ready (so you put in “delay” until you find the culprit). Or you use a debugger like Script Debugger, or you use a logging feature to log every step to figure out where it breaks.

Or you query here at MacScripters. I usually beat myself again the digital wall on my own for a bit until I come here, just in case it’s something obvious. In other words, just that error message is not enough info. :wink:

Post the script, maybe someone here can give a hand.

While I would love to be able to post the script… I can’t (as far as I know). It’s an Automator plugin and I don’t see any script. It’s listed as a Workflow file. Even the script in my scripts menu is unopenable with Script Editor.

Maybe I’ve posted in the wrong forum. I DID see an Automator forum on here too. But it was after I had already posted.