error on compiling

When I try to run a very basic script program in xcode 4.2 I get the following error sheet.

Xcode cannot run using the selected destination
Choose a destination with a supported architecture in order to run on this system.

I have a script that I made on a prevoius version of Xcode that runs fine.
The only difference that I can find between the 2 version is that in the old version I can choose it to run on

MyMac 32 bit
in the scheme popdown menu.

My only choice with the new program is 64 bit. If I change the old program to 64 bit, I get the same error message. I am running snow leopard (my computers are too old for lion).

So my question is can I do something to give me a choice to run 32 bit or am I looking in the wrong place.


in Target > Build Settings is the basic SDK set to “Latest Mac OS X (.” or 10.6
and Architectures to Standard (32/64-bit Intel) ?

If you click on the very top item (with the app icon) in the files pane on the left, this will bring up a screen in the editor that has a validate settings button at the bottom center. Click that and it will bring down a sheet with suggestions for fixing the app. Just click “perform changes” and that should update it so it runs on Xcode 4.


Tried both idea’s
It was set for latest Mac OS X.
I am running Snow Leopard which I thought was 64 K (10.6.8)
But above that there is a pop up is labled architectures.
In it I could change it to 32 bit. The program now runs
Thanks for both your help and for pointing me in the right direction.