ffmpeg and applescript

ok so, i have a working build of ffmpeg on my computer. it works fine in terminal, but using the same commands in my applescript i get an error saying that there was an I/O error and the input file was corrupted.


here is a thread with a script using ffmpeg.

Hope it helps

nope that didnt help. any other ideas?

bump. i tested the ffmpeg build using terminal and it works fine, just not when its executed in applescript.


strings working in the terminal but not in AppleScript
have mostly wrong escaped characters like qoutes

nope, i copied the exact code from the script into terminal and it worked

That’s what I mean:
a string, which works perfectly in the Terminal, could not work in AppleScript
because some special characters have to be escaped.

so, could you show me an example of a wroking ffmpeg command in applescript?

the string in the mentioned thread above works.
Maybe it would be better that you post your string which doesn’t work, so we can see the syntax

"ffmpeg -i video.flv -f mp4 -s 320x240 video.mp4"

Where is ffmpeg located on your system? You should try using the full path to the executable.

Bruce is right.
If the ffmpegX app is in the Application folder, the shell string should start with

"/Applications/ffmpegX.app/Contents/Resources/ffmpeg "...

damn. Same error, i tired my own build of it and the one in ffmpegX same error…

Where are the video files located? How are you referring to them?

they are in the home folder, so i should have to have a path to them. correct?

actually i put ~/ before the filename and it worked. thanks!