Filemaker 7 error

I keep getting the following error “Expected end of line but found “.” from this script when trying to compile. I just upgraded to FMP7.03 because I have some written in 7.01 the same way and they compile. Here is my code to the point that it stops.

set skulist to {}
set temp to display dialog “Please enter the Item# for this Product.” default answer “”
set SKU_Code to text returned of temp
set SKU_String to SKU_Code as string
tell application “FileMaker Pro”
tell database 1
tell table “Price”
show (every record of table “Price” whose cell “sku” is equal to SKU_String)
end tell
end tell
end tell

Any Ideas???

Sorry if this seems “educational”.

I tried to replicate the problem, but can’t from the code you sent, it compiles fine.

This sounds either like a weird FM bug, or a problem locating the AS bug. Have you tried replacing the suspect portion of the code with a sample known to work?

I do believe it is a bug somewhere. That part of the code is the first few lines. I can compile every thing else fine, so I switched the same code over to FMP 7 developer and it compiled fine. Thank you very much for your reply. If you have any other thoughts I would like to hear them.

It’s not a bug so much as it’s unexpected. In FileMaker 7 a “table”, accessed from AppleScript is actually a “table occurence” (TO) in FileMaker (i.e., the name in the Relationship Graph, not the “base table” name in Define Database). The base table could be named something else, and seems inaccessible. Which in a way makes sense, since even layouts are assigned to a particular TO, not the base table.

name of every table
and you’ll see what I mean. So tell the TO and it will work.