Finder: set bounds of window = 'Parameter Error'?

Hi Forum,

I have this problem:

after I execute one ‘read’ of window bounds i can’t execute any set bounds command in the Finder anymore until i restart the Finder:

  1. Script
tell Application "Finder"
get bounds of first window
  1. Script
tell Application "Finder"
set bounds of first window to {50, 50, 300, 300}
-- set properties of first window to {bounds:{50, 50, 300, 300}} -- has the same result
end tell

When I run script 2 after script 1 it results a ‘Parameter error’,
when i restart the finder and run only script 2 it works regardlessly.

I Googled and got one older hit at describing the same phenomenon - but without solution:

I suspect the problems might have begun when I ran a script which tried to set the bounds of a finder window to an illegal value.

Anybody an idea how to fix this? Is it a known problem - maybe a bug in AS?

Many thanks for your help in advance.


(I’m running OS X 10.4.4 - AppleScript 1.10.3)

What if you uninstall every scripting addition in the regular dirs? (/Library and ~/Library)

Hi jj,
many thanks - I didn’t know I have something installed at all but I found:

Adobe Unit Types

After removing this everything seems to work fine again. Probably it’s the Quark osax - buggy as the whole application :wink:


It is. I can confirm :wink: