FireFox 1.5 and the Applescript Protocol Link?

Hi all …

I recently updated to FireFox 1.5, which is a great browser. However, I’ve run across a small problem …

When I click on a AppleScript Protocol link in this BBS [and elsewhere], I get the typical popup asking me if I want to launch Script Editor as the external application. The problem is, once you get that dialog, there aren’t any buttons to tell it yes or no. You only get the checkbox to remember that setting, with one hugmongus dialog.

I’ve tried various things, such as re-installing FireFox, to other methods and none worked. I also checked the internal settings, “about:config”. Unfortunately, there are so many settings, I’m not sure which one controls this behavior.

I suspect this has more to do with Tiger OS security, although I’m not absolutely sure if this is a Finder/OS X thing, or something related to FireFox, or both.

I can’t help but think I’m not the only one whose run across this. If anyone has stumbled on this issue and figured out a workaround, please share it with us.

Many Thanks!

The AppleScript Protocol link works for me (after asking me once only) in both Safari and Camino. Must be something to do with Firefox.

A quick test throwed the following:
-Open the “about:config” page.
-Filter using “applescript”.
-Setup “network.protocol-handler.external.applescript” as “true” (double-click if “false”).
-Setup “network.protocol-handler.warn-external.applescript” as “false” (double-click if “true”).


You’re not the only one. It’s a bug. The buttons are actually there – I think they’re just being pushed off-window by the long message text.


Go to the page about:config like jj said.
Filter on Applescript.
If you have 1.5, you probably won’t see any keypairs
Right-click in the empty list and select new

Enter “network.protocol-handler.external.applescript” as the name.
I have this set to false, but jj has it set to true. The setting of this value doesn’t seem to matter for the purposes of opening scripteditor. jj may be able to explain this. I can’t.

Right click to add another new keypair called “network.protocol-handler.warn-external.applescript”. Set this to false. That means you will no longer get the warning screen with no buttons when you click an “open in scriptedit” link. In fact, you won’t get any warning at all – it will just open up in the script editor. It’s up to you to read the script before you run it. (-;

I don’t think you need to restart the app to activate the changes.

A related problem and the found culprit is here.