G4 Beats G5 hands down on speed!!

Hi fellow scripters,

Just a general subject for discussion really, not just OS X related.

I have a script runing at a site on 2 machines, which is identical. One machine is a 466 G4 runing OS 9 & QXP 5, the other is a 1.8 G5 running 10.2.8 & QXP 6.1.

The script which batch prints Quark files to PS runs 3 to 5 times faster on the G4 than the G5! - Neato :?

The only down side is the G4 get an ‘Out of memory’ error if you try to run more than 650 or so QXP docs.

Any clues as to the speed difference?

Also, any clues as to the memory limits of 9?



About the speed, my theory is that unix needs to have all kinds of information stored while Macintosh OS doesn’t use as much.

About the script, you could itry increasing the memory to your script application just like any other application in OS 9.


Differences may be due to the different versions of Quark. I’ve heard about slow processes in 6.x…

I agree with jj… the difference is likely to be in the AppleScript implementation in XPress, not anything directly to do with the machine itself.

If you ran XPress 6.1 on the OS 9.x machine you’d probably find it ran slower there, too.

To get a better comparison you might try running the Quark 4 script on the G5 machine in classic mode instead of comparing the Quark 4 to the Quark 6 script.

To respond in some kind of order:

Unix bit probably right, I don’t know UNIX well enough to comment.
Even after putting the app memory upto 250mb, still had the same issue at the same point.

Qxp 6 is a slow as a slow thing put on hold!!

Ditto. But haven’t tried 6.1 on the G4.

Had major issues withthe script under classic - loads of weird errors. Couldn’t be arsed to try to re-write the code. May do later though!

Did try something else in the past, which was to save the page as an EPS instead. The speed increased more on the G5 than the G4 and were almost equal. Even though the trusty G4 still pipped the G5 to the post!!

This may not have much to do with your out of memory errors, but I run into the same thing with FreeHand 8 as it leaks memory like a sieve. After a couple hundred documents memory gets low. I’ve worked around this by simply rebooting FH every so often.