How to make the icon not show up in the dock and hidden...

How do I make my Automator (or ScriptEditor app) icon NOT show up in the dock and become hidden while still having the app still run? Does this make sense?



Add this to your app’s .plist:


Peter B.


  1. Right click the app and choose “Show Package Contents”.
  2. Open the Contents folder and open the info.plist file.
  3. There should be a key LSUIElement (or Application is agent (UIElement) if Raw keys are not shown). This should be checked. (Note: You can create this key if necessary.)
  4. Save and close.


so far nothing is working :frowning: :confused:

Every single time I want to load the app I have to go through and deal with the think in the info.plist file. It doesn’t seem right that I should have to deal with that every single time I want to launch the program. Is there any applescript code that I can put in the beginning of my script?



Regarding Automator…

You might try saving your Automator workflow as a workflow instead of saving it as an application.

Highlight the saved WFLW file and perform a Get Info on it. Under “Open with” click the popup button and select Automator Launcher.

Tested using Mac OS 10.4.11 and Automator v. 1.0.5. Good luck.


Make your final script edits to the app with it visible. Then change the .plist. Then make a zip archive of the app… and trash the original. Unzip the archive and…

Should work.

Peter B.


I have this little app which is called “Dock Dodger” which does the steps for me automagically.
Not zipping and such, but it takes care of the LSUIElement setting.

It has always worked, and I found it through google. (It’s a timesaver)

Best Regards