Huh? "Required Resources not found -192"

Recently, I have been hearing from users of my scripts that the error message “Could not run this script because the required resources were not found. -192” keeps cropping up. These are reliable and venerable scripts that could be up to three years old; no modifications to them and I am unable to duplicate the error. It occurs with a wide and random variety of scripts, applets, droplets, and so on. However, a common factor among the users might be that they are using Intel Macs. Does anyone have a clue how to correct for this error? I don’t have an Intel Mac to test these scripts on, but don’t believe the problem is with the actual script and suspect it may be something on their Macs. Thoughts most appreciated!

Hi Doug

Post one of your scripts which you think maybe causing some bother and i’ll test it on my MBP
Or point towards which one it is on your website! (you are the itunes applescripting dude! aren’t you)


Here are three randomly selected emails from users experiencing the problem, including links to the scripts:

I haven’t had any problems with Quick Convert on my Intel MBP (OS X v10.4.8).

Hi Doug

I’m getting “Could not run this script because the required resources were not found. -192”
when i use Quick convert and backup purchased not tried the third!

MBP 10.4.8

Hi Doug

Quick convert works when run from script editor…
not had chance to test the others!!!

Thanks for looking into this, you guys.

As you can see, there seems to be an inconsistent problem. I had rarely run into the “required resources” error ever before, but lately I’ve been seeing a lot of it from correspondents. I’m not even sure what the resources required might be a reference to. Thanks again for your help and any further ideas.

What happens if the scripts are re-saved as apps (maybe as bundled) from Script Editor

Not what I was hoping to find.

Error Numbers and Error Messages: Operating System Errors

Nor I, Bruce.

I think I may have seen that definition, and, as discouraging as it seems, I was hopeful that perhaps it was less rare under more modern conditions (it has been in my experience) and that these conditions could be or have been determined.


Did you use the “Installer” script to install the downloaded files? If so, could you try just dragging fresh copies of the scripts from the .dmg to the iTunes Scripts folder? A longshot, but I wonder if the installer script is not copying all of a script file’s resources.

OK, I think I nailed this.

For those of you who have not been following along: several users have contacted me about a rare “Could not run this script because the required resources were not found. -192” error. This thing is so rare I have probably only seen it once or twice myself in my years of scripting. Here’s the problem: my new “Installer” script that accompanies the latest .dmg download packages does not (currently) correctly copy AppleScript Studio apps. Some downloads use the “ProgBar” app, for example. In some download packages, the “ProgBar” app bundle is not completely copied; only its “Contents” folder is copied to your iTunes Scripts folder. This is totally fixable.

But here’s the weird thing: when a folder named “Contents” is in your [username]/Library/iTunes/Scripts folder it somehow inhibits other scripts from running correctly.

What will happen is that when you run a script you will see its Splash Screen. None of the scripts from my site have been saved with this option. When you click the Run button, the -192 error appears.

Remove the “Contents” folder from your iTunes Scripts folder and the scripts will run correctly.

Here’s what’s weirder: create an empty folder named “Contents” in your iTunes Scripts folder and the same error occurs!

I am now updating the “Installer” script to handle AppleScript Studio apps correctly, and then this problem should disappear. If you are experiencing the -192 error, go to your [username]/Library/iTunes/Scripts folder and remove the folder name “Contents”. In a few days, downloads which contain an AppleScript Studio application can be re-downloaded and re-installed correctly.

My sincere thanks to Correspondent Christian who figured out the “Contents” folder weirdness. And thanks to everyone who responded here. I am anxious to hear of any confirmations of this error-fix.