Impossible to automount AFP drive through Chooser in Classic

I take care of a Mac lab in which Quark 5 (classic only) is being used on OS X boxes. We have network storage for the users of this lab to store their projects. The network share is being served from a Windows 2000 server running apple services. This means the client must authenticate using Microsoft’s User Authentication Module (UAM). The problem we’ve encountered is that if a user mounts the drive using OS X’s “Connect to Server…” function, the files tend to corrupt. We can get around this by having the user mount the drive via the chooser.

I’ve tried coming up with an AppleScript that tells the chooser to mount the drive. The best I can do is get the chooser (and classic) to open and then prompt with the OS X version of the MS UAM. This really isn’t acceptable because it’s just the same as mounting using OS X.

I’ve also tried booting into 9 and moving the server alias from Recent Servers to the Servers folder in the System Folder, but this results in a bad alias error message.

Does anyone have any suggestions? It’s really a hastle to get users to mount a drive using Chooser, and I’d love to be able to automate the process.


I don’t have any way of checking this, but can’t you connect AFP using Chooser and then check “Log me in on startup” (or whatever it is), which will require that the user logs in using a username and password every time Classic starts?

This might work, but as I say, I have no way of checking (No AFP here).


Nope. The box that you usually can check next to the share name is greyed out. I think it’s either because the connection is made via the MS UAM (which does not allow passwords to be saved) or because it’s a Windows server.

Just a thought:

How about creating a login script, saving this as an application and then putting this in they startup items of OS9? (When you save the script as an application, you can try “require Classic environment”.)

I tried something similar. I think since the chooser is not scriptable, once it is opened OS X takes over because it realizes OS 9 is trying to mount a drive. I’m not sure that it’s possible to accomplish this feat.

I can’t test it properly, but save the following script (replacing the volume name, etc. with your data) as Run only application and requiring Classic environment. It apparently works under certain OS9 environments, but not others. Put the resulting application in the start items folder for Classic.

mount volume "VolName" on server "ServName" as user name "UserName" with password "PassWord"

I get an error -5016 (which is apparently “Server not responding”) when I start Classic, which casts a ray of hope.

I get the same error, but I can connect using the Chooser. When I go through the chooser, I get prompted witht the MS UAM login utility. Thanks for your suggestion.

Looking at other scripts to open UAM volumes, I notice that you need additional UAM-related stuff, thus (I found this on the web):


Would I just put this in a tell application “Finder” statement? Also, should it have the %20’s in it, or is that a type-o. I’m assuming zone means appletalk zone, but I’m not sure there is one for the Win server because it doesn’t show up in the chooser. Also, what is “Authent.” Thanks so much for all your help!

No, the %20s aren’t typos; they are used to present the correct info to the UAM thing. The code I presented allows you to log in without authentication (always a nice thing).

I suspect that the zone is either “*” or blank.


tell application "Finder"
		mount volume "afp://;AUTH=No%20User%20Authent@[Servername]/[vol]"
	end try
end tell

The thing is, I’m trying to use the Microsoft Authentication Module, so AUTH should not equal No User Authent. I’m not quite sure what it should equal, but there’s one for Kerberos and such, so I just need to find out what to put there. Even then, I’m guessing since I say Finder (even though I will have selected “Require Classic Environment” that it will just pop up with the OS X MS UAM password prompt, not the OS 9 one. :frowning:

mount volume is part of the standard additions scripting addition, so there is no need for the tell finder portion of the script. In the script that I have written for our servers at work I use the numeric IP address in place of the server name, works in both OS 9 and OS X. However I have not tried logging onto a Windows server so I do not have any experience with that part of the log in.

Try looking at:

You need to enter the correct type of authentication and then the username and password.

Try (this sends a clear text password, which is probably not good if you’re logging in outside a local network).

Mount volume "afp://myname;AUTH=CLEARTXT%20PASSWRD:mypass@server/volume"

Hope this helps