Indesign CC close Missing Fonts modal message from Creative Cloud

I have looked everywhere to find out how to turn off the Missing Fonts message in Indesign CC.
Everything I have found does not work.

This comes up when opening a file. We don’t care about the missing fonts at this point in time. All we want is the pictures.

I found this but it did not work
–if (name of window 1 is “dialog1”) then tell application “System Events” to key code 76

User interaction Level in the Indesign dictionary says it should do it but I can not make that work either.,

Thanks in advance for any help pointing me in the right direction for this.


OSX 10.9.5
Indesign CC 2014

It works. Tested with latest CC 2014

set documentPath to "iMac Mavericks:Users:adminosx:Desktop:test.indd"

tell application "Adobe InDesign CC 2014"
	set user interaction level of script preferences to never interact
	open file documentPath
end tell

Ame - Stefano

Thank you Ame
That works great.

This was the best I could make work But I had no way to test for dialog boxes. So it only worked for the initial message.
Later messages still stopped me.

tell me to CloseDialogBox()
on CloseDialogBox()
tell application “Adobe InDesign CC 2014”
delay 2
–if (name of window 1 is “dialog1”) then
tell application “System Events” to key code 76

	end try
end tell

end CloseDialogBox

Thanks Again

Hi OakMan,

the script works for each file you can open. Dialogs is suppressed.
If you need to know if a layout contains missing font you need to get all fonts used by document and see if they are missing.
I use in in production and works.

Ame - Stefano