Indesign CS3 applescript broken with Snow Leopard

I have been using a couple of scripts written under 10.4 for InDesign CS3. They are fairly simple, but some parts appear to be broken now that I have updated my system to Snow Leopard. eg,

tell application "Adobe InDesign CS3"
	set myDialog to make dialog with properties {name:"File Naming Options"}
	set myResult to show myDialog
end tell

This used to work, but no longer works under 10.6.

This however does still work:

tell application "Adobe InDesign CS3"
	display dialog (get id of application "Adobe InDesign CS3")
end tell

Any ideas how I can find out what has changed under 10.6?


I don’t believe this is a scripting issue. I’ve had the same thing happen to me twice, and I solved it by throwing away the application preferences for CS3.

Thanks Marc, I’ll try that and report back.

I did some tests yesterday with CS5 (rather than cs3) / snow leopard, and the script does indeed work with that combination. I hope you’re right!



Just tried ditching the CS3 prefs - and my script works perfectly once more. How bizarre!

Many,many thanks - you’ve saved me hours of attempted re-scripting!