Internet Connect / AppleScript Not Working on MBP?


First, thank you for taking the time to read this!

Here is what i’m trying to do… I want to write a simple script that checks to see if my MacBookPro is on it’s home network, and if so, to run the script that mounts the network drives. If it’s not on the home network, then run another script that mounts them with SSH/SSHFS.

The two mounting scripts work great - no help needed there.

Where i’m having the problem is…

tell application "Internet Connect"
set vNetwork to network name of AirPort configuration 1
Display dialog "Current Network: " & vNetwork
end tell

i’ve also tried:

  • signal level; result = 0
  • network type; result =
  • AirPort power; result = 0

Do i have to do something different since it’s an Intel Mac?

The book i’m reading is called AppleScript The Missing Manual. They have a section in there on this and i’ve typed word for word and still nothing.



Model: MacBookPro Duo Core 2 2.16 2g Ram
AppleScript: 1.10.7
Browser: Safari 419.3
Operating System: Mac OS X (10.4)

Hi Chris

Same result here:(

Check out this post:
Do a search for internet connect on here and you will see a few frustrated scriptors.
Unless we are all doing something wrong then scripting this on an intel mac is very flakey!!

I even switched internet connect to run under rossetta and it told me i didn’t have a network ,signal or anything yet i could still
see my signal strength in the menu bar and i still was on the net:/

Maybe someone else has an idea.

It’s not just Intel Macs… I just posted for the same problem on that thread.

Model: PowerBook G4
AppleScript: 1.10.7
Browser: Firefox
Operating System: Mac OS X (10.4)