Library Disappeared

Why would one of my libraries in Script Editor disappear? When I opened a script, everything was all jumbled, so I looked for the library for the application with jumbled code and readded it, then restarted the editor and it worked again. But why would it disappear in the first place?

Last time I’ve seen something like this is with an osaxen that isn’t intel compatible (universal binary) when I tried to run scripts on a new intel iMac. All the library commands/events/objects turned into their raw format (<>) and wouldn’t run.

But mine won’t come back because my script editor is now made for intel chip, or something, and every time I compile a script with calls to an application (or osax) that isn’t Universal, it turns back into raw event format.

Interesting. I’m on a G5 at work (where it happened), but I wasn’t switching between Intel and Motorola chips. When I said “jumbled” I meant what happened to you: it turned to the raw format.

I don’t know what osaxen is, so I don’t know if my script has that.