MacScripter migration

MacScripter was apparently migrated to a new host yesterday (2017-07-11) and with a new installation of the BBS software. Ray and his developer have been working to reinstate the MacScripter-specific changes which were introduced to the old installation over the years, but there have inevitably been one or two teething problems and instances of features going astray. You may also find that you’ve had to log in again manually since yesterday.

Ray sends his apologies and would love to know of any problems or omissions so that they can be fixed. I’ve started this thread so that people can report any problems they discover (assuming the software will let them post them! :wink: )

I’ve already reported:

  1. Having to log in manually on the first visit after the change.
  2. Not being able to hide the various groups of fora on the index page.
  3. Certain characters not being rendered correctly.

Edit: To which I would add:
4. Not being logged in after posting. (This may be something to do with the fact that the site domain in the browser changes from to
5. The displayed posting time being an hour out. (You have to check a “daylight savings time is in effect” box in your profile to get the right display).
6. The arrows in the thread listings next to threads with new posts don’t change colour, although the subject lines are rendered in bold type.

On the bright side, the text side seems a lot kinder to ageing eyes :slight_smile:

On my side, this morning I was able to enter macScripter with Firefox or with Safari Technology Preview but not with the standard Safari.
Finally, the problem disappeared after cleaning the history. I don’t understand why it did except if clearing History clear also caches.
Like Shane I noted that the font used has a greater size which is fine for my old eyes.

Thanks to everybody which worked to make these changes.

Yvan KOENIG running Sierra 10.12.5 in French (VALLAURIS, France) mercredi 12 juillet 2017 13:51:21

I can almost read it without putting mine in. :wink:

  1. No smiley buttons on the posting page.

I had to log in manually with Firefox, after which I was redirected to being not logged in at! However, when I tried again, this time I was logged in automatically.


I had to log in with Firefox and Safari Technology Preview but I was absolutely unable to enter with Safari - until I cleared the application’s history.

I missed the fact that the smileys are gone but we may always read “Smilies:: on” below the text area.
How did you inserted one in your message to Shane ?
I tried to insert one thru the system’s character palette but it appears in the text area but in the preview it’s replaced by an awful code. :roll_eyes:

Yvan KOENIG running Sierra 10.12.5 in French (VALLAURIS, France) mercredi 12 juillet 2017 14:56:41

Hi everyone
I am the developer working with Ray to migrate the site. Sorry for all the troubles with the URL resolving back and forth and any other issues. One thing to try is to clear the browser cache/history. It looks like I need to force the site to resolve to the non-www url on first visit and then it will work correctly. If you have a saved favorites link you might re-add it. The long numbers that used to be an IP address, that looks as if it is IPv6 address instead of IPv4 your ISP may be using IPv6 now. I did see the smilies issues but happened to overlook it on my final pass. Was more concerned on the AppleScript button and format.

If you get redirected to a blank site you’ll need to clear the DNS cache in OS X with this

OS X Mavericks+

sudo killall -HUP mDNSResponder

Any older OS X please just search “clear my DNS cache” I don’t have the correct syntax

Test rendering issues- I will take a look at this after fixing the url redirecting.

If you start getting redirected to the non-www url after logging in/posting. I am working on this issue.

If someone to explain how the groups were able to be hidden on the Index page. I didn’t see this during my comparing of the live and test version before the switch. Was it the ability to collapse the categories down to just on cat open and shorten the screen?

I made a change to the settings and it should be doing a check to see if Daylight Savings time is enable in your timezone and adjust accordingly. If this doesn’t fix that then See the first post from Nigel.

The arrows not turning orange is definitely my fault. I did see this and just overlooked it.

The font size was Ray’s idea and I battled with what size to increase it with. I only raised it 2 points and thought that raising it another 2 might be even better. Suggestions open.

My main complaint would be that my last post appeared to post successfully at the time, but does not actually show in the thread, including a lost script I wrote. Bad timing with the migration, I guess.

It was in this thread:

And I typically don’t save scripts I write as solutions to other people’s problems here, because I figure I can just get them back out of the forum if I ever want to see them again.

EDIT: - In fact, the last post from TheREDNAVE that I was replying to is also missing.

Sorry for this. Yes it was bad timing between the posts and putting the site into maintenance mode. I can see if Ray can get me another pull of the old database and restore those posts if possible.

On another note the unicode characters are a result of migrating the Database to utf-8 from the update of FluxBB software. I’ll try to find a fix for this soon. I am only seeing this in the post text and code snippets not anywhere else. I had seen this in the breadcrumb section on the top and bottom of the page and fixed this on my end and do not see it now.

When I go to my profile and click “Show all posts,” I get “Bad request. The link you followed is incorrect or outdated.”

finally after so many years FluxBB updated. So can we finally use the tags it supports?

Like [del]deleting old text[/del]


Oh yeah :cool:

Hi odomtech.

Thanks for the update and comments and for your efforts.

I was getting redirected to www urls after posting to or logging into non-www ones. The non-www domain has been MacScripter’s address for years, but your comment seems to suggest that the www domain is now correct. Could you please confirm?

Yes. Each group of forum names below the blue bars on the index page could be collapsed to leave just the blue bars. This state would be remembered on subsequent visits until the user clicked on a bar to reveal that group again. Since I rarely changed it once I’d set my own preference, I can’t actually remember exactly what had to be clicked, or what the instructions were, to collapse a group. I think there was a grey dot at the right end of each bar which would turn red (or orange) when there were new posts in one of its groups.

This is a very welcome change if it works automatically. :slight_smile: Before, the site treated the time in the user’s time zone as a fixed offset from its own. This meant that for us in Europe and elsewhere, the displayed times were an hour out for a couple of weeks twice a year, thanks to the different clock-change dates in the US.

I’m still seeing it in the page number links for the topic lists and long threads.

Thanks again.

By the way, an extra line’s being inserted after quotes. Previously, a gap of zero or one lines between what the user quoted and his/her reply resulted in a one-line gap in the displayed text. Now, a one-line gap after a quote is appearing as a two-line gap.

And while I’m on a roll ( :wink: ), in my posts above (and here) where I mentioned, I didn’t use URL tags to turn it into a link. They were inserted by the system. Is there any way to stop this?

Edit: I’m still logged into after posting this, so that little issue seems to have been resolved. :slight_smile:

I redid my lost comment/script, but every time I try to post it on the thread:

I just get:

EDIT: It did, at some point, appear to post. I also got “There has been an error” when I posted this comment.

Also, the “Subscribe to this thread” links seem to be missing.


I adjusted the Base URL setting in FluxBB to the non-www url after reading everyones comments. This may have fixed this. Not sure yet, but will still put in a permanent fix (.htaccess) to keep everything lined up right.

Like this
edit: can someone point me to a post that has images in it. I think I found another myself

I am not to sure how this works from Flux. I just know the setting is available in your profile.

I have noticed this also and I think I found where this is coming from. Stay tuned.

I have seen this code that does this. I didn’t realize it wasn’t the way it was before will talk with Ray about this.

posted a reply in the topic in question.

Yes! +/- and a dot. Funny how you can see something several times a day and not be able to call it to mind when it’s gone. :rolleyes:

Good I have found it then. That was a screenshot of my development server. Found some other things that I missed and will have those post soon. Having to work on the registration part for Ray first and then will have the stuff in this thread worked on. Thanks for all the input.

I will be posting new code to the site for the next few minutes addressing some of the issues that have been brought to my attention.

Edit: Updates to the site today:

1.added the ability to collapse forum categories on the index page back to the site.(missed this feature during my comparing)

  1. added the smilie bar back :):|:(:D:o;):/:P:lol::mad::rolleyes::cool:
  1. made the style changes to the [new posts] back to the original orange/red triangle and orange dot to the right of the forum category.
  1. adjust the font a bit more if it seems to much or if the width of the page needs to be adjusted let me know.

Found this in the settings and turned it off.

Character encoding issues is a fix I’m looking into. only things currently effected are old posts that was encoded in one format and then converted during the migration process.

If I have not addressed a specific issue as of yet it is still on the task list of things to look at

for me:

  1. Had to log in manually

  2. Operating system selection is still not to current OSX specs, stops at 10.10

I am uncertain how I can display a screen shot, never had to do it, it shows some text issues
can some one please advise as to how I can do this please.

yes this is due to the migration

Thank for the heads up I haven’t noticed this one. Headed their now to look at it. as I’m running 10.12.6
Edit: Added all versions up to 10.13 dev beta 3