main.m file error?

when i set my apps build config to release it decied to start giving me errors when i compile it. it says there was something wrong with the main.m file and says something about the command failing with gcc. heres my main.m file…

[code]extern void ASKInitialize();
extern int NSApplicationMain(int argc, const char *argv[]);

int main(int argc, const char *argv[])

return NSApplicationMain(argc, argv);


What is the actual error?

gcc-3.3: installation problem, cannot exec `cc1obj’: No such file or directory

bump…and i did a clean all thing and it didnt fix it.

bump…please i really need help on this one.


The error is because of the version of compiler you have set. To fix the problem go to terminal and type…

sudo gcc_select 4.0
enter password

restart xcode nd now you should be able to compile your project!

Hope this helps, report back and let us know!

yeah i tried that and it didnt work, but i just made a new xcode project and copied the code and interface and it worked.