Mount Server

I have a script to mount all the volumes in Applescript / Xcode, wich works fine. I use this line :

mount volume ("afp://" & inlogNaam & ":" & wachtWoord & "@" & IPnummer1 & "/" & volumeNaam1_3) as string

The script makes it possibele to login on 4 different server, and for each server 5 different volumes.
Just one small problem: the first time a server will be mount (the first volume) he comes up with the dialog window, and the user must click “return” for the script continues.

Is there a way to avoid this? Then it will be perfect :slight_smile:


What is the dialog that comes up and does it always come up? I tried your script here and it seems to work alright. I have a similar script to choose from a list of possible volumes to mount and occasionally the script will error saying that a volume cannot be found and when I run it again it gives me the same error but mounts the volume anyway. I posed a question about this behavior on here about a year ago and no one could come up with a reason why this happens. I don’t know if this is the same problem you’re having or if it is entirely different.


It works great, the only thing is that the first time you mount the server he comes up with a dialog box and you must give a return.
After you have mount the server and you mount a second volume on this server he don’t come with a dialog box.

So in my case, with 4 different servers and about 14 volumes to mount I must press return 4 times and I’m looking for a way to avoid this.

The dialog box is the one with the username and password. Thinking of this, maybe it’s because we don’t use a password … i’ll try that tomorrow morning :wink:

Yep, that’s the problem. If I create an account with a password in stead of ‘blanc’ it works just fine :slight_smile: