Mounting a volume

I have tried using scripts I have found here to mount a windows server onto my laptop (OSX)
and always get an error.

I can mount the required volume through the “connect to server”. I was wondering if there was a way to obtain the IP when the volume is mounted.

The scripts found and used always give me an error, 1 or 36. The other thing that happens when it half works is the “connect to server” dialog box comes up with none of the information (password and user name) I have supplied in the script.

Any help here would be appreciated
Sean Balfe

It would probably help if you posted the script here so that we could see what might be going wrong.

You might be able to use ‘netstat -an’ in the to get the IP of the other machine.

I have looked at my Network preferences, and in the window the IP is supplied (DHCP)

When I place this in mount volume “afp://” as user “1234” with password “1234”
I get a error box:
Connection Failure
This file server is running on your machine. Please access the volumes and files locally.

Have I obtained the wrong IP?

I have even tried the TCP/IP network version mount volume
mount volume “afp://user:password@”

What is next?
Sean Balfe

The IP address shown in your Network preferences is your own. The error messages explains that you are trying to mount your own machine. You need to find out the IP address of the machine whose drive you want to mount. Go to its Network preferences to get its IP address.

Also, I believe you need to include the volume you want to mount, not just the whole computer. Example:

mount volume "afp://172.16.3.XX/VOLUME_NAME" as user "1234" with password "1234"

Replace XX with the IP address of the machine you want to connect to, and VOLUME_NAME with the drive/shared-volume you want to mount.

I used my network utillity and I’m sure I have the correct IP. However when I use the script, I now get a Type -1 Error.

I encounter this error occasionally. It’s just started recently and it might be related to the 10.2.8 update, but I can’t say for sure. I generally restart the computer that’s running the script to get around it. This always seems to fix it.

– Rob

Strange. I’ve seen weird problems like perfectly valid mount volume statements failing. Restarting normally fixed the problem for me. You might want to specify the volume you want to mount, as well, though. If you don’t, you get a dialog showing the available volumes to choose from.