Multi-Ad Creator Script Issue

I am guessing most of you have never used i Multi-Ad Creator but I am hoping someone can help. After doing a version update (rom 8.04 to 8.54) I started to have a script issue. (running os 10.4.11)

the script is functional (resides in my attached script folder)

but after it runs

i loose functionalty from the Creator application (ex: all the file functions are grayed out…key commands dont work) if i remove the script and restart the program the functionality returns (*i have attempted to isolate the issue with say “1”, say “2” etc etc at key points in the script. the script doesnt appear to exit cleanly …after “end if” the script will not respond with a “say #”)

below is the script …basically it is auto pdf proofer…upon save it allows the user to send a proof to specific destination folder

property PDFPath : “AD-GRAPHICS:PDF_Proofs:”

using terms from application “MultiAd Creator Pro”
on saved theDoc
set question to display dialog “Send Proof?” buttons {“Yes”, “No”} default button 2
set answer to button returned of question
if answer is “Yes” then
set fileName to name of theDoc
set destFolder to PDFPath

        --Trim off .crtr extension if it has one:
        if fileName ends with ".crtr" then
            set sd to AppleScript's text item delimiters
            set AppleScript's text item delimiters to {"."}
            set fileName to (text items 1 thru -2 of fileName) as text
            set AppleScript's text item delimiters to sd
        end if

        tell application "MultiAd Creator Pro"
            export PDF current spread of theDoc saving in (destFolder & fileName & ".pdf") print order user order export method composite resolution limiting 300 black and white compression use zip color image compression use JPEG quality 80 with embed no base 14 fonts, use doc size, binary encoding and compress text and line art without print as spreads, crop marks, registration marks, color bars, document notes, plate information, text blocks only and presentation mode
        end tell
    end if
end saved

end using terms from

example from above

	end tell
		say "1"
	end if
	say "2"
end saved
say "3"

end using terms from

it doesnt say “3”

Hello and welcome to Macscripters!

Say “3” is outside your “on saved theDoc” Event. So it is not part of what is to be executed, when the on saved theDoc event is triggered.

ok thank you. lol that explains that.

now why would it execute the script but then cause the program to malfunction??

the script worked in the older version of the program 8.04



I have really no idea why it makes the program malfunction. Maybe the event handler should return something, I don’t really know, as I don’t run that app, but have a go at the documentation.

As to why the say statement worked, -I really shouldn’t try to guess, as it would all be speculations, so I don’t know! :slight_smile:

But hopefully, it all should work better for you now, now that the culprit is identified.