network password authentication

I have tried searching for an answer to this, but can not seem to find one.
I have multiple users in OS9.2.2, connecting to multiple servers. I am trying to write a script that prompts them to enter the username and password only once, then connects to all the servers (one of our primary applications crashes when connecting using Apple’s built in automount feature in the Chooser, plus its annoying to enter your password 5 or 6 times).

I can get the script to prompt for username and password (which is masked thanks to 24U’s Appearance OSAX), and then try to connect to all the servers. The problem is that the servers will not authenticate (I get an error in the script: “Network File Permission Error.”)

The portion of the script in question:

mount volume “afp://ServerName/Share” as user name user_name with password my_password

If I remove the password portion of it:
mount volume “afp://ServerName/Share” as user name user_name
it prompts me for the password and mounts normally. This would be fine, except I would ideally want to eliminate the need for the user to enter their password a bunch of times.

I assume this is some sort of security mechanism in the server(s). Is there any way to bypass this?

I discovered that my script works in OS8.6-9.0.4, however, to make it work in OS9.1-9.2.2, I had to modify it slightly. I changed the mount line to:

mount volume “Share” on server “ServerName” as user name user_name with password my_password

That seems to have solved it.