Newbie and applescript with xtool

Hi all
I can’t seem to get xtool.osax to work. I’ve got an applescript to open safari and make it full screen, and I want to hide the mouse cursor or move it to a screen edge.

I’ve been trying to get it working with but I can’t do it. Whenever I enter ‘movemouse(100,100)’ I get a syntax error and ‘temp hide mouse’ barfs the same.

I’m not convinced the applescript dooberry has ‘registered’ xtool. I’ve dropped the osax into all the library folders I can see but still no go.


Hi bazzer,

scripting additions must be installed either in /Library/ScriptingAdditions/ or in ~/Library/ScriptingAdditions/

Hi Stefan
Thanks for the quick response. Done that. Still no… I’ve got a feeling that the issue may be down to me trying it on a brand new MiniMac - it’s an Intel not a PPC. :frowning:

Yes, that could be the problem. XTools is a PPC OSAX

Mmmm, back to the drawing board then :frowning:

Thanks anyway.

XTool was the best osax for moving the mouse and clicking for free or for money. Will someone please continue development on a Snow Leopard compatible version? Please!

You can get a free tool from my website here.

Thanks so much, Hank! That is perfect!