NSReceiverEvaluationScriptError; 4 (1)

I believe I posted my question in the wrong forum initially. I don’t see a way to move it to this forum so I’m left with copying and pasting my question here. Sorry if that causes a problem.

I was trying to make an Automator plugin action that would save a file in a particular format for use with Sound Studio 3. The plugin does what it’s supposed to do but when it’s finished it throws up the Applescript error “NSReceiverEvaluationScriptError; 4 (1)”

I googled the error and came up with a forum posting that said it was the result of a SIMBL plugin. The poster said that he removed the plugin and everything was fine. So, I did a Spotlight search and discovered that I had that plugin on my laptop. I dragged it from the library and deposited it on my desktop and restarted my machine. Then I tried the automator plugin and it seemed to work just fine without an error dialog. So, I concluded that the SIMBL plugin was the problem.

I then tried using the Automator plugin some more to convert some Sound Studio files to a different format and the very first file I tried gave me the error message. Every file after that did the same. It appears that the Automator plugin is doing what it’s supposed to do (except that the dialog interrupts the flow) but I still come up with that NSReceiverEvaluationScriptError; 4 (1) message.

Any ideas?


Do you have “enable assistive devices” enabled in your Universal Access prefs within your system prefs ?:rolleyes:

Model: G4 FW800
Browser: Safari 419.3
Operating System: Mac OS X (10.4)

Wow! It has been almost 7 full months since I posted the original question. I never did find a reason or explanation for the problem that I had. However, to answer the question: No, I do not have that enabled.

Model: MacBook Pro
Browser: Firefox
Operating System: Mac OS X (10.4)

Sorry, I must have been away on a time lapse somewhere. 7 months, indeed wow.

I only answered as I have seen numerous posts regarding your error message and this seems to be how others have fixed this error message.

I maybe wrong ! Give it a go and see how it goes. It may work :slight_smile: